Помогите срочно в паскаль abc.1. Написать программу нахождения среди чисел от 1 до 100...

0 голосов
56 просмотров

Помогите срочно в паскаль abc.
1. Написать программу нахождения среди чисел от 1 до 100 всех пар чисел, для которых их сумма равна их произведению)
2. Написать программу вычисления куба суммы всех четных чисел от 2 до 100
3. Каждая бактерия делится на две через три минуты. В начальный момент имеется одна бактерия. Написать программу, определяющую, сколько будет бактерий через N минут


Информатика (21 баллов) | 56 просмотров
Дан 1 ответ
0 голосов
1.
uses crt;
const n=100;
var i,j:integer;
begin
for i:=1 to n do
for j:=1 to n do
if i+j=i*j then
writeln(i,' ',j);
end.
2.
uses crt;
const n=100;
var i:integer;
begin
for i:=2 to n do
write(power(i,3),' ');
end.
3.
uses crt;
var n:integer;
begin
read(n);
writeln((n div 3)*2);
end.
(8.2k баллов)
0

Прошу сделай 3 задачу через цикл while если не сложно