Напишите программу которая выводит ** экран столбец матрицы, сумма значений элементов...

0 голосов
349 просмотров

Напишите программу которая выводит на экран столбец матрицы, сумма значений элементов которая наименьшая


Информатика (12 баллов) | 349 просмотров
Дан 1 ответ
0 голосов

Const nx=30; mx=30;
var r:array[1..nx,1..mx] of integer;b:array[1..mx] of integer;
i,j,n,m,k,sum,min:integer;
begin
min:=40;
randomize;
write('Введите n,m: ');readln(n,m);
writeln('Исходная матрица: ');
for j:=1 to m do begin
for i:=1 to n do begin
r[i,j]:=random(20)-10;
sum:= sum + r[i,j];end;
b[j]:=sum;sum:=0;
end;
for i:=1 to n do begin
for j:=1 to m do begin
write(r[i,j]:4);end;
writeln;end;
writeln;
for j:=1 to m do begin
write(b[j]:4);
if min > b[j] then begin
min:= b[j]; k:= j;end;
end;
writeln;writeln;
for i:=1 to n do begin
for j:=1 to m do begin
if j=k then write(r[i,j]:4);end;
writeln;end;
end.

(6.5k баллов)