С++ Напишите программу, которая в четырехзначном числе меняет местами цифры сотен и...

0 голосов
109 просмотров

С++
Напишите программу, которая в четырехзначном числе меняет местами цифры сотен и десятков.
Вывести полученное число.
Ввод Вывод
1267 1627


Информатика (66 баллов) | 109 просмотров
Дан 1 ответ
0 голосов

//Microsoft (R) C/C++ Optimizing Compiler Version 19.00.23506 for x64

#include
using namespace std;
int main()
{
    int number; 
    cin >> number;
    number = 1000 * (number / 1000) + 100 * (number / 10 % 10) + 10 *
(number / 100 % 10) + number % 10;
    cout << number;<br>}

(4.2k баллов)
0

Спасибо не забудьте сказать..