Помогите составить программу. Паскаль.

0 голосов
30 просмотров

Помогите составить программу. Паскаль.


image

Информатика (56 баллов) | 30 просмотров
Дан 1 ответ
0 голосов

Program qwe;
var
a,max:integer;
begin
writeln('vvedite chislo');
readln(a);
max:=0;
repeat
      if max< (a mod 10) then max:=(a mod 10);
      a:=a div 10;
until ((a mod 10)=0) and ((a mod 100)=0);
writeln('max=',max);
readln;
end.

(340 баллов)