Помогите составить программу в паскале.Расчет значения функции x-2/sqrt(x*x-2*x) при х...

0 голосов
44 просмотров

Помогите составить программу в паскале.Расчет значения функции
x-2/sqrt(x*x-2*x) при х из отрезка (-10;10) изменяющимся с шагом 1.Должен быть цикл for.Заранее спасибо


Информатика (27 баллов) | 44 просмотров
Дан 1 ответ
0 голосов
Правильный ответ
PascalABC.NET 3.3.5, сборка 1662 от 29.04.2018
Внимание! Если программа не работает, обновите версию!

begin
  for var x:=-10 to 10 do
    Writeln(x:3,x-2/Sqrt(x*x-2*x):15:10)
end.

Как видно из представленных во вложении результатов, современный Паскаль легко справляется и с отрицательным значением подкоренного выражения (NaN - Not a Number - не число) и с делением на ноль (-infinity - минус бесконечность).

image
(150k баллов)
0

нужно паскаль именно не net а обычный

0

Верю. Но об этом надо писать в вопросе, уважая труд других людей, а не после получения ответа.

0

Значит, этим решением воспользуются другие люди, у которых возникнет этот же вопрос, но не будет ваших ограничений на версию.