Напишите программу, которая вводит с клавиатуры числа до тех пор, пока не будет введено...

0 голосов
323 просмотров

Напишите программу, которая вводит с клавиатуры числа до тех пор, пока не будет введено число 0. В конце работы программы на экран выводится минимальное и максимальное из введенных чисел (не считая 0).

Входные данные
На вход программы подаются целые числа, по одному в строке. Ввод завершается числом 0.

Выходные данные
Программа должна вывести минимальное и максимальное из введенных чисел (не считая 0) в одной строке через пробел.


Информатика (15 баллов) | 323 просмотров
0

На языке Паскаль

0

Ну ты нашёл задачу котору тебе решили ?

Дано ответов: 2
0 голосов
Правильный ответ

Program p1;
uses crt;
var max,min,a:integer;
begin
read(a);
max:=a;
min:=a;
while a<>0 do begin
read(a);
If (max< a) and (a<>0) then begin
max:=a;
end;
 If (min>a) and (a<>0) then
 min:=a;
 end;
 write(max,'    ', min);
 end.

(324 баллов)
0 голосов

Javascript:var м=[],ч;while(true){ч=prompt();if(ч==0)break;else м.push(prompt());}alert(Math.min.apply(null,м)+" "+Math.max.apply(null,м));

0

ТОгда понятно почему вы имеете такое отношение к паскалю

0

Именно так я и решаю задачи на паскале

0

Во всех языках есть недочёты

0

Ну для язык на втором плане на первом что в черепной коробке потому что язык можно выучить + к этому он может и умереть очень быстро

0

для меня * )