Напишите программу, которая суммирует все четные числа от 15 до 25, а для всех нечетных...

0 голосов
50 просмотров

Напишите программу, которая суммирует все четные числа от 15 до 25, а для всех нечетных находит сумму квадратов этиз числех


Информатика (12 баллов) | 50 просмотров
Дан 1 ответ
0 голосов

Var i,sum,summ: Integer;
begin
for i:=15 to 25 do
begin
if i mod 2=0 then Inc(sum,i) else
if i mod 2<>0 then Inc(summ,(i*i));
end;
writeln('Чётные: ',sum);
writeln('Нечётные: ',summ);
end.

(5.6k баллов)