Ввести 6 чисел. Определить каких больше - четных или нечетных. Надо написать программу **...

0 голосов
39 просмотров

Ввести 6 чисел. Определить каких больше - четных или нечетных. Надо написать программу на языке паскаль очень прошу срочно.


Информатика (12 баллов) | 39 просмотров
Дан 1 ответ
0 голосов
program nazvanie;
var a,b,b1,k,k1:integer;
begin   
 write('Введите трехзначное число: ');
   
  readln(a);
 
   b:=a;
 
   while b<>0 do
     begin        b1:=b mod 10; 
    if b1 mod 2=0
     then       k:=k+1          else      k1:=k1+1; 
 b1:=b div 10;
 
   b:=b1;
 
 end;
 
   if k>k1
        then         
write('Кол-во четных цифр больше, чем нечетных в числе ',a)
else if k          then   write('Кол-во нечетных больше, чем четаных в числе ',a);
end.   
Немного переделать и будет рабочая прога!
(62 баллов)