Написать программу для вычисления объема куба по введённой длине ребра. Если введеное...

0 голосов
86 просмотров

Написать программу для вычисления объема куба по введённой длине ребра. Если введеное число меньше либо равно нулю то сообщить об жтой ошибке пользователю. Обязателен диалог компьютера с пользователем! " Здравствуйте! Вас приветствует программа для расчета ... Введите целое/дробное число... Результат: ... куб.см."


Информатика (33 баллов) | 86 просмотров
Дан 1 ответ
0 голосов

Var a: real; begin   Write('Здраствуйте я умею считать объем кубика! Введите длину ребра: ');     while true do   begin     Read(a);     if a < 0 then Writeln('Меньше нуля, серьезно? Попробуй еще раз: ');     if a = 0 then Writeln('Ноль, серьезно? Попробуй еще раз: ');     if a > 0 then break;   end;     Writeln('Объем кубика равен ' + a*a*a);   Writeln('Пока! :)'); end.

(94 баллов)
0

Что этоо!?

0

XD

0

Aaaaa

0

Итс э кодэ, мисье

0

оу, простите, синьёр

0

...ита. сеньорита

0

надеюсь разобрались с кодом :D

0

вопрос не мой)) но я разобролась))