Напишите программу , которая по двум данным числам [ a,b] ( включая концы отрезка)...

0 голосов
37 просмотров

Напишите программу , которая по двум данным числам [ a,b] ( включая концы отрезка) Программа получает на вход два натуральных числа a и b . Программа должна вывести одно число : количество чётных чисел на отрезке [ a,b ]
Входные данные :10 , 20
Выходные данные : 6


Информатика (20 баллов) | 37 просмотров
Дан 1 ответ
0 голосов
Правильный ответ

Program ryazantsev;
var a,b,i,count:integer;
begin
readln(a, b);
count:=0;
for i:=a to b do if i mod 2=0 then count:=count+1;
writeln(count)
end.

(106 баллов)