Написать программу, которая запрашивает массив из N элементов, а затем делит все элементы...

0 голосов
151 просмотров

Написать программу, которая запрашивает массив из N элементов, а затем делит все элементы массива на минимальный элемент. Протестировать программу на пассивах размерностью 5 и 10 элементов.


Информатика (27 баллов) | 151 просмотров
Дан 1 ответ
0 голосов
Правильный ответ

Программа со статическим массивом:

Var
  M: array[1..32767] of real;
  Min: real;
  N, i: integer;
Begin
  Write('N = ');ReadLn(N);
  if (N <= 0) then<br>    WriteLn('Количество элементов должно быть положительно')
  else
  begin
    Write('Введите элементы массива в количестве ',N,' штук');
    For i:= 1 to N do
      Read(M[i]);
    Min := M[1];
    For i:= 2 to N do
      if (M[i] < Min) then
        Min := M[i];
    WriteLn;
    Write('Получившийся массив:');
    For i:= 1 to N do
    begin
      M[i] := M[i] / Min;
      Write(' ',M[i]);
    end;
  end
End.

(6.6k баллов)