СРОЧНО! напишите программу которая получает с клавиатуры 2 целых числа и вычисляет их...

0 голосов
348 просмотров

СРОЧНО! напишите программу которая получает с клавиатуры 2 целых числа и вычисляет их произведение, используя только операции сложения. пробить через repeat(постусловие) pascal abc очень прошу


Информатика (19 баллов) | 348 просмотров
Дан 1 ответ
0 голосов
Правильный ответ

Var a,b,c,sum:integer;

begin
readln(a,b);
sum:=0; inc(a); c:=0;
repeat
sum:=sum+b;
inc(c);
until c=a;
sum:=sum-b;
writeln(sum);
end.

(314k баллов)