Написать программу по блок-схеме

0 голосов
27 просмотров

Написать программу по блок-схеме


image

Информатика (141 баллов) | 27 просмотров
Дано ответов: 2
0 голосов
Правильный ответ
PascalABC.NET 3.3.5, сборка 1662 от 29.04.2018
Внимание! Если программа не работает, обновите версию!

begin
  var (a,b,c):=ReadReal3;
  var d:=b*b-4*a*c;
  if d<0 then Writeln('Корней нет')<br>  else
    if d=0 then begin
      var x:=-b/2/a;
      Writeln('Корень уравнения x=',x)
      end
    else begin
      var x1:=(-b-Sqrt(d))/2/a;
      var x2:=(-b+Sqrt(d))/2/a;
      Writeln('Корни уравнения: x1=',x1,', x2=',x2)
      end
end.
(150k баллов)
0 голосов

Паскаль
Var
A, B, C, D, x1, x2:integer ;
Begin
Readln(a, B, c) ;
D:=(sqr(b)-4*a*c);
If d<0 then <br>Writeln(''корней нет'')
Else
If D = 0 then
X1:= (-b) /2a
Writeln(x1) ;
Else
If D > 0 then
X1 :=( - b + sqrt(d)) /(2*a)
X2:=(-b-sqrt(d))/(2*a)
Writeln(x1, x2)
End.

(99 баллов)
0

Эта программа не будет работать, в ней ошибки.

0

Причем не просто ошибки, а ДЕВЯТЬ ошибок.

0

Когда пишете программу в ответе на задание, проверяйте ее в трансляторе.