(Паскаль) Написать программу которая запросит ввести с клавиатуры 3 числа и выведит **...

0 голосов
56 просмотров

(Паскаль) Написать программу которая запросит ввести с клавиатуры 3 числа и выведит на экран большее из них. Если числа равны программа должна вывести надписть, что числа равны.


Информатика (101 баллов) | 56 просмотров
Дано ответов: 2
0 голосов
Правильный ответ

//PascalABC.NET
//Версия 3.3.5, сборка 1650
begin
var (a,b,c):=ReadReal3;
if (a=b) and (b=c) then write('числа равны') else write(max(max(a,b),c));
end.

(149k баллов)
0 голосов

Program qq;
uses CRT;
var a,b,c,max:longint;
begin
readln(a);
readln(b);
readln(c);
max:=a;
if b>max then
max:=b;
if c>max then
max:=c;
if (a=b)and(b=c)and(a=c) then
writeln('Числа равны')
else
writeln(max);
end.

(1.1k баллов)