Напишите программу которая выводит сумму всех чисел кратных 8 и больших 40

0 голосов
53 просмотров

Напишите программу которая выводит сумму всех чисел кратных 8 и больших 40


Информатика (71 баллов) | 53 просмотров
0

на каком языке

0

??

0

паскаль абс

0

хорошо

Дан 1 ответ
0 голосов

PascalABC.NET
Версия 3.3.5 Сборка 1662 (29.04.2018)
var n, i, a, sum : integer;
begin
  readLn(n);
  sum := 0;
  for i :=0 to n do
  begin
    readLn(a);
    if (a mod 8 = 0) and (a > 40) then
    begin
      sum := sum+a;
    end
  end;
  writeLn(sum);
end.

(1.5k баллов)