Напишите программу в Pascal Дано трехзначное число х. Если х-четное число, то вычислить...

0 голосов
50 просмотров

Напишите программу в Pascal
Дано трехзначное число х. Если х-четное число, то вычислить сумму цифр этого числа. Если х-нечетное, то вычислить число-перевертыш


Информатика (17 баллов) | 50 просмотров
Дан 1 ответ
0 голосов
Правильный ответ
PascalABC.NET 3.3.5, сборка 1662 от 29.04.2018
Внимание! Если программа не работает, обновите версию!

begin
  var n:=ReadInteger('n=');
  var (s,d,e):=(n div 100, n div 10 mod 10,n mod 10);
  if n.IsEven then Writeln(s+d+e) else Writeln(e,d,s)
end.

Примеры
n= 531
135

n= 428
14
(150k баллов)