Напишите программу вычисления a и b и сравните их, если x=10: a:=(x+6)*scr(x)-sqrt(x-1);...

0 голосов
33 просмотров

Напишите программу вычисления a и b и сравните их, если x=10:
a:=(x+6)*scr(x)-sqrt(x-1);
b:=abs(x-15)*sqr(x+1)/242;
Срочно . Даю 99 баллов


Информатика (127 баллов) | 33 просмотров
0

На каком языке программирования?

0

Я хз нам в тетради сказали написать.

0

Почему нарушение

0

Не полная задача. Никто не решит, поскольку не указан язык программирования для написания программы.

0

begin var x:=10; var a:=(x+6)*Sqr(x)-Sqrt(x-1); var b:=Abs(x-15)*Sqr(x+1)/242; Writeln('a=',a,', b=',b,', a-b=',a-b)end.Результатa=1597, b=2.5, a-b=1594.5

0

зачем?

0

Спасибо)

Дано ответов: 2
0 голосов
Правильный ответ

Код на руби

x = 10
a = (x+6)*x*x-(x-1.0)**0.5
b = (x-15).abs*(x+1)**2.0/242
p [a,b,a-b]

Вывод
[1597.0, 2.5, 1594.5]

(55.0k баллов)
0 голосов
PascalABC.NET 3.3.5, сборка 1659 от 09.04.2018
Внимание! Если программа не работает, обновите версию!

begin
  var x:=10;
  var a:=(x+6)*Sqr(x)-Sqrt(x-1);
  var b:=Abs(x-15)*Sqr(x+1)/242;
  Writeln('a=',a,', b=',b,', a-b=',a-b)
end.

Результат
a=1597, b=2.5, a-b=1594.5
(150k баллов)