Составьте программу ** языке Паскаль: Вводится величина угла в градусах. Найти его sin и...

0 голосов
40 просмотров

Составьте программу на языке Паскаль: Вводится величина угла в градусах. Найти его sin и cos.


Информатика (300 баллов) | 40 просмотров
0

Напомним, что в Паскале аргумент тригонометрических функций задается в радианах

Дано ответов: 2
0 голосов
Правильный ответ
PascalABC.NET 3.3.5, сборка 1660 от 20.04.2018
Внимание! Если программа не работает, обновите версию!

begin
  var a:=DegToRad(ReadReal);
  Writeln('Cинус равен ',Sin(a):0:13,', косинус равен ',Cos(a):0:13)
end.

Пример
38.4
Cинус равен 0.6211477802783, косинус равен 0.7836934573258
(150k баллов)
0

Паскале аргумент тригонометрических функций задается в радианах, разве нет?

0

var a:=DegToRad(ReadReal); это он считывает переменную в диапазоне real

0

понятно, спасибо

0

большое спасибо!

0 голосов

Var a:real;
begin
read(a);
b:=sin(a);
c:=cos(a);
write(b,' ',c);
end.

(633 баллов)