Составьте программу, которая находит сумму чисел, обратных числам целым числам от 1 до N,...

0 голосов
40 просмотров

Составьте программу, которая находит сумму чисел, обратных числам целым числам от 1 до N, т.е. S=1/1+1/2+1/3+...+1/N.


Информатика (12 баллов) | 40 просмотров
Дан 1 ответ
0 голосов

Program abc;

var
  n, i: integer;
  s: real;

begin
write('Введите количество чисел: ');
  readln(n);
  for i := 1 to n do
    s := s + 1 / i;
  write('Сумма обратных чисел = ', s);
end.


image
(2.3k баллов)