Помогите пожалуйста нужно написать программу в паскале. Задача 1. Найти площадь...

0 голосов
34 просмотров

Помогите пожалуйста нужно написать программу в паскале. Задача 1. Найти площадь закрашенной фигуры если известны стороны прямоугольника и радиус круга Задача 2. Найти гипотенуза прямоугольного треугольника если известно его площадь и один из катетов. Числа можете подставить любые


Информатика (70 баллов) | 34 просмотров
0

А рисунка нет?

0

Нет к сожалению

0

Дам 50 баллов

0

Боже да как это делать ??!!!

Дан 1 ответ
0 голосов

1. Ну я не знаю какая часть фигуры закрашена. Будем считать что прямоугольник находиться в окружности и необходимо из площади курга вычесть площадь прямоугольника.
const
p =3.14;
var
a,b,r,s1,s2:real;
begin
Writeln('Введите длины сторон прямоугольника');
readln(a,b);
Writeln('Введите радиус окуржности');
Readln(r);
s1:=a*b;
s2:=p*sqr(r);
Writeln('Площадь закрашеной окружности = ', s2-s1);
end.

Если закрашена какая-то другая область то можете просто изменить действие с площадями в предпоследней строчке ( в данном случае мы из s2 вычитаем s1).

(894 баллов)