Напишите программу ** Паскале, которая находит y=a/b, когда b равен 0 и b не равен 0

0 голосов
46 просмотров

Напишите программу на Паскале, которая находит y=a/b, когда b равен 0 и b не равен 0


Информатика (141 баллов) | 46 просмотров
Дано ответов: 2
0 голосов
Правильный ответ
var a,b:real;
begin
readln(a,b);
if b=0 then writeln('Деление на 0')
else writeln('y = ',a/b);
end.

Пример:
5 2
y = 2.500000000000000e+00
(194k баллов)
0 голосов

Program abc;var y,a,b:real;beginreadln(a,b);y:=a/b;if b=0 then writeln('Ошибка данных')else writeln(y);end.

(494 баллов)
0

program abc;
var y,a,b:real;
begin
readln(a,b);
y:=a/b;
if b=0 then writeln('Ошибка данных')
else writeln(y);
end.

0

Немного подправил, чтоб глаза не резало)