Для каждой задачи составить программу, выводящую значение TRUE, если указанное...

0 голосов
162 просмотров

Для каждой задачи составить программу, выводящую значение TRUE, если указанное высказывание является истинным, и FALSE - в противном случае (использовать условный оператор нельзя)
5. Данные числа x, y являются координатами точки, лежащей в первой координатной четверти.
6. Данные числа c и d являются соответственно квадратом и кубом числа а.


Информатика (267 баллов) | 162 просмотров
Дан 1 ответ
0 голосов
Правильный ответ
PascalABC.NET 3.3.5, сборка 1640 от 17.03.2018
Внимание! Если программа не работает, обновите версию!

begin
  // 1
  var (x,y):=ReadReal2('Введите x и y:');
  Writeln((x>0) and (y>0));
  // 2
  var a,c,d:longint;
  Write('Введите число, его квадрат и куб: '); Read(a,c,d);
  Writeln((a*a=c) and (a*a*a=d))
end.

Пример
Введите x и y: 3.5 1.8
True
Введите число, его квадрат и куб: 15 225 1225
False
(150k баллов)