Напишите программу, которая получает с клавиатуры номер месяца и выводит название...

0 голосов
1.1k просмотров

Напишите программу, которая получает с клавиатуры номер месяца и выводит название соответствующего ему время года или сообщение об ошибке.
Пример:
Введите номер месяца:
5 . В программе ПАСКАЛЬ!!! Не использовать case


Информатика (22 баллов) | 1.1k просмотров
Дан 1 ответ
0 голосов
Правильный ответ

Program n_5;

var
  a: integer;

procedure Error;
begin
  write('ERROR');
  exit;
end;

begin
  write('Введите номер месяца - ');
  readln(a);
  if (a <= 0) or (a > 12) then
    Error
  else
  if (a = 12) or (a = 1) or (a = 2) then
    write('Зима')
  else
  if (a = 3) or (a = 4) or (a = 5) then
    write('Весна')
  else
  if (a = 6) or (a = 7) or (a = 8) then
    write('Лето')
  else
  if (a = 9) or (a = 10) or (a = 11) then
    write('Осень');
end.

(1.2k баллов)