(99 баллов!) Python Напишите программу, которая находит в массиве минимальный и...

0 голосов
547 просмотров

(99 баллов!)
Python
Напишите программу, которая находит в массиве минимальный и максимальный из чётных положительных элементов.Если в массиве нет элементов с чётными положительными значениями,нужно вывести сообщение об этом.


Информатика (49 баллов) | 547 просмотров
Дан 1 ответ
0 голосов
Правильный ответ
mas = [int(i) for i in input('Введите массив : ').split()]
flag = 0
for i in mas:
    if i%2 == 0:
        max = min = i
        flag = 1
        break
if flag == 0:
    print('Четных нет!')
    exit()
for i in mas:
    if i%2 == 0 and i > max:
        max = i
    if i%2 == 0 and i < min:
        min = i
print(max,min) 
(440 баллов)
0

какой массив вводишь?

0

2 36 44 5 66 7 89 90

0

90 2 вывел

0

у меня

0

я прикрепил файл решения

0

чекай

0

Я ввожу тот же самый массив,потом он хочет что бы я ввела что-то ещё

0

как ты вводишь?

0

просто введи строку через пробел

0

и нажми enter