Помогите написать программу,** паскале,заранее спасибо,очень нужно

0 голосов
24 просмотров

Помогите написать программу,на паскале,заранее спасибо,очень нужно


image

Информатика (12 баллов) | 24 просмотров
Дан 1 ответ
0 голосов

Program n20_2;
var a, s:integer;
begin;
repeat    
readln(a);
if (a mod 2 = 0) and (a>15) and (a<190) then s+=a;<br>until a = 0;
write(s);
end.

(336 баллов)
0

Спасибо огромное))

0

Можно вопрос? Что такое repeat( не проходили такого)

0

Типа повторить?

0

Ещё. untill,что это?

0

Repeat/until - цикл, который повторяется пока выполняется условие, но в отличие от while он всегда выполняется хотя бы один раз. Если вы это не проходили, лучше заменить его на это:

0

program n20_2;
var a, s:integer;
begin;
readln(a);
while a<>0 do begin;
readln(a);
if (a mod 2 = 0) and (a>15) and (a<190) then s+=a;<br>end;
write(s);
end.

0

А там разве If должен быть?

0

Спасибо

0

If нужен, чтобы проверить, принадлежит ли число интервалу и является ли оно чётным.

0

Ой, только что заметил, что программа должна выводить 'net', если нет чётных чисел, принадлежащих интервалу. Замени "write(s)" на "if s>0 then write(s) else write('net');"