Нужно написать программу в Паскале Дан механизм,состоящий из двух шестеренок. У одной...

0 голосов
47 просмотров

Нужно написать программу в Паскале
Дан механизм,состоящий из двух шестеренок. У одной шестеренки N зубцов,у другой K. Требуется найти какое минимальное число поворотов на один зубчик требуется сделать,чтобы шестеренки вернулись в исходное состояние.


Информатика (12 баллов) | 47 просмотров
Дан 1 ответ
0 голосов

Program task;
var i,n,k:longint;
begin     
writeln('n?');     
readln(n);     
writeln('k?');     
readln(k);     
for i:=1 to n*k do begin       
if ((i mod n = 0) and (i mod k = 0)) then begin         
writeln(i);         
break;       
end;     
end;     
readln;
end.

(592 баллов)