Программу,решающую следующую задачу: дано трёхзначное число.Составить программу вывода **...

0 голосов
68 просмотров

Программу,решающую следующую задачу: дано трёхзначное число.Составить программу вывода на экран числа, полученного перестановкой цифр сотен и десятков.Помогите пожалуйста за 34 бала


Информатика (17 баллов) | 68 просмотров
Дано ответов: 2
0 голосов

Написано на языке Python !!!

n = int(input())
e = n%10
d = n//10%10
s = n//100
print(d*100+s*10+e)

(2.7k баллов)
0 голосов

Var a,b,c: integer;
Begin
write('Ведите трёхзначное число: ');
readln (a);
b:=a div 100;
c:=a mod 100 div 10;
writeln('Число, полученное перестановкой цифр сотен и десятков: ',c,b)
End.

Var a,b,c,d: integer;
Begin
write('Ведите трёхзначное число: ');
readln (a);
b:=a div 100;
c:=a mod 100 div 10;
d:=a mod 10;
writeln('Число, полученное перестановкой цифр сотен и десятков: ',c,b,d)
End.

(PascalABCNET)

(3.9k баллов)