Даю 50 баллов! Задача по информатике: С клавиатуры вводится расстояние в метрах....

0 голосов
68 просмотров

Даю 50 баллов!
Задача по информатике:

С клавиатуры вводится расстояние в метрах. Напишите программу, которая находит число полных километров и метров (пример: вы ввели число 4501, в результпте которого вы получите: 4501м=4км 501м)
ПОМОГИИИИТЕ!


Информатика (267 баллов) | 68 просмотров
Дано ответов: 2
0 голосов
Правильный ответ
PascalABC.NET 3.3.5, сборка 1640 от 17.03.2018
Внимание! Если программа не работает, обновите версию!

1. Современное решение

begin
  var m:=ReadInteger('Введите расстояние в метрах');
  var (km,mm):=(m div 1000,m mod 1000);
  Write(m,'км = ',km,'км');
  if mm>0 then Writeln(' ',mm,'м') else Writeln
end.

Пример
Введите расстояние в метрах 4501
4501км = 4км 501м

2. Так часто учат писать в школе

program Perevod;

var
  m,km,mm:integer;
 
begin
  Write('Введите расстояние в метрах');
  Readln(m);
  km:=m div 1000;
  mm:=m mod 1000;
  Write(m,'км = ',km,'км');
  if mm>0 then Writeln(' ',mm,'м')
  else Writeln;
end.
(150k баллов)
0 голосов

Плиз лучший ответ
///////////////
program d;
var
n:integer;
begin
writeln('Введите число(Метры)');
readln(n);
writeln('Километры ', n div 1000);
writeln('Метры ', n mod 1000);
readln;
end.

(716 баллов)