Написать программу, которая вычисляет сумму первых n целых положительных чётных чисел....

0 голосов
129 просмотров

Написать программу, которая вычисляет сумму первых n целых положительных чётных чисел. Паскаль


Информатика (51 баллов) | 129 просмотров
Дан 1 ответ
0 голосов
Правильный ответ

1)
// PascalABC.NET 3.3

begin
  var n:=readInteger;
  writeln(SeqGen(n,2,x->x+2).Sum);
end.

2)
var n,s,i:integer;
begin
readln(n);
s:=0;
for i:=1 to n do s:=s+2*i;
writeln(s);
end.

Пример:
5
30

(194k баллов)