Напишите программу( в паскале авс), которая находит НОК (наименьшее общее кратное) двух...

0 голосов
74 просмотров

Напишите программу( в паскале авс), которая находит НОК (наименьшее общее кратное) двух чисел, введённых с клавиатуры.


Информатика (46 баллов) | 74 просмотров
Дан 1 ответ
0 голосов

Для решения этой задачи воспользуемся формулой:
а*б=НОД(а,б)*НОК(а,б)
var a,b:longint;
function nod(a,b:longint):longint;
begin
if a= 0 then
nod:=b else
if b=0 then
nod:=a else
if a>b then
nod:=nod(a mod b,b) else
nod:=nod(a,b mod a);
end;
Begin
read(a,b);
writeln((a*b) div nod(a,b));
End.

(2.8k баллов)