Написать программу которая проверяет -является ли сумма цифр заданного трехзначного числа...

0 голосов
68 просмотров

Написать программу которая проверяет -является ли сумма цифр заданного трехзначного числа четным числом


Информатика (85 баллов) | 68 просмотров
Дан 1 ответ
0 голосов

C++
size_t sum(size_t val)
{
     static size_t temp = 0;
     if (val > 0) {
         sum(val / 10);
         temp += val % 10;
     }
     return temp;
}  
int main()
{
     (sum(123) % 2) == 0 ? cout << "True" : cout << "False";   <br>}

(4.2k баллов)