(** языке C++) ! напишите программу!!! как сделать типа пишешь 123 а тебе выдаёт 3+2+1=6...

0 голосов
47 просмотров

(на языке C++) ! напишите программу!!! как сделать типа пишешь 123 а тебе выдаёт 3+2+1=6
пример
674= 7+6+4=17
431= 4+3+1=8
и.т.д


Информатика (103 баллов) | 47 просмотров
Дано ответов: 2
0 голосов
Как-то так
size_t sum(size_t val)
{
     static size_t temp = 0;
     if (val > 0) {
         sum(val / 10);
         temp += val % 10;
     }
     return temp;
}
(4.2k баллов)
0 голосов

//работает только для 3-ех значных чисел.
#include

using namespace std;
int main()
{   
int s,a,b,c,i;   
cin >> i;   
a = i / 100;    
b = i / 10 % 10;   
c = i % 10;   
cout <<a<<"+"<<b<<"+"<<c<<"="<<a+b+c;<br>return 0;
}

(614 баллов)