Написать программу для вычисления выражения: s=1!+2!+3!+...+15!

0 голосов
25 просмотров

Написать программу для вычисления выражения: s=1!+2!+3!+...+15!


Информатика (29 баллов) | 25 просмотров
Дан 1 ответ
0 голосов

Program pr1;
const n=8;
function factorial(n:integer):integer;
begin
if (n<=1) then factorial:=1<br>else factorial:=n*factorial(n-1);
end;
begin
WriteLn('n!=',factorial(n));
end.

(22 баллов)
0

А почему там const=8?