Ввести массив из 10 положительных чисел. Программа должна посчитать сумму чисел кратных...

0 голосов
49 просмотров

Ввести массив из 10 положительных чисел. Программа должна посчитать сумму чисел кратных 5.

Написать программу PascalABC .


Информатика (125 баллов) | 49 просмотров
Дан 1 ответ
0 голосов
Правильный ответ

Var a : array [1..10] of integer ;
 
begin  
for var i:=1 to 10 do    read(a[i]);  
var s:=a.Where(t->( t mod 5 = 0));  
Writeln('Cумма: ',s.Sum)
end.

(314k баллов)
0

Можешь помочь , просто такие команды не проходили ... Учитель не засчитывает (
Выручай :D

0

var a : array [1..10] of integer ;
sum:integer;

begin sum:=0;
for var i:=1 to 10 do begin
read(a[i]);
if a[i] mod 5 = 0 then sum+=a[i]
end;
Writeln('Cумма: ',sum)
end.

0

а так?

0

Ну посмотрим )
Пасиб ;)