Помогите решить задачу в Paskal: Составьте программу для решения задачи,которая...

0 голосов
25 просмотров

Помогите решить задачу в Paskal:
Составьте программу для решения задачи,которая проверяет,может ли ребёнок посещать детский сад ,т.еего возраст до 6 лет.Посчитайте через сколько лет он станет школьником .


Информатика (17 баллов) | 25 просмотров
Дан 1 ответ
0 голосов
Правильный ответ

Program Test;

Var Vozrast: integer; Bol, Mistake: boolean;

Begin

Bol := true;

Write('Введите возраст ребенка: ');
Readln(Vozrast);
Writeln();

if (Vozrast > 6) then
Writeln('Ребенок не может посещать детский сад')

else if (Vozrast <= 0) then <br> begin
Writeln('Некорректный ввод данных!');
Mistake := true;
end

else
begin
Writeln('Ребенок может посещать детский сад');
Bol := false;
end;

if (Mistake = false) then
begin
if (Bol = false) then
Writeln('Ребенок станет школьником через ', 7 - Vozrast, ' лет')

else
Writeln('Ребенок уже в школе');
end;

End.


image
image
(13.4k баллов)