Напишите программу ** паскале, которая сообщает нам: -если оценка 3 или 4 или 5 , то...

0 голосов
54 просмотров

Напишите программу на паскале, которая сообщает нам:
-если оценка 3 или 4 или 5 , то "экзамен сдан"
-если оценка 2, то "не сдан", иначе "нет такой оценки"


Информатика (72 баллов) | 54 просмотров
Дано ответов: 2
0 голосов
Правильный ответ
// PascalABC.NET 3.3, сборка 1634 от 14.02.2018
// Внимание! Если программа не работает, обновите версию!

begin
  var n:=ReadInteger('Введите оценку от 2 до 5:');
  case n of
  3..5:Writeln('Экзамен сдан');
  2:Writeln('Экзамен не сдан');
  else Writeln('Нет такой оценки')
  end
end.
(150k баллов)
0 голосов

Program proverka;
var a:integer;
begin
write ('Введите оценку: ');
readln (a);
if (a=3) or (a=4) or (a=5) then writeln ('экзамен сдан')
else if (a=2) then write('не сдан')
else write('нет такой оценки');
readln
end.

(3.9k баллов)