Ребятушки,помогите прошу...информатика..Составьте программу ** языке Паскаль которая...

0 голосов
15 просмотров

Ребятушки,помогите прошу...информатика..Составьте программу на языке Паскаль которая запрашивает любое двухзначное число а на выходе дает перевернутое число.


image

Информатика (15 баллов) | 15 просмотров
Дан 1 ответ
0 голосов
Правильный ответ

Var a,b,c: integer;
Begin
write('Введите двузначное число: ');
readln (a);
b:=a div 10;
c:=a mod 10;
writeln('Перевернутое число: ',c,b)
End.

(3.9k баллов)
0

а что такое b:=a div 10 и c:=a mod ?

0

div - получение целого частного (в данном случае от деления на 10) mod - получение целого остатка (в данном случае от деления на 10)

0

если я ввиду 21 к примеру,он мне даст 12?

0

ну ,я имею ввиду он поменяет местами

0

Да. 21/10 = 2 (целое частное) и 1 (целый остаток). a = 21 b = 2
c = 1 При выводе просто пишем эти переменные в обратном порядке. Сначала с, затем b.

0

спасибо огромное!!!!