Написать программу: найти сумму четных и нечетных n-чисел

0 голосов
39 просмотров

Написать программу: найти сумму четных и нечетных n-чисел


Информатика (19 баллов) | 39 просмотров
Дан 1 ответ
0 голосов

Program zzz;
var a, b, n, i, ss, s : integer;
begin 
WRITELN ( ' введите количество чисел' );
readln (n);
s := 0;
ss := 0;
For i := 1 to n do
begin 
if i mod 2 =0 then
s:= s+i
else
ss := ss + i;
end;
WRITELN ( 'Сумма четных чисел равна  ',s );
WRITELN ( 'Сумма нечетных числе равна  ' , ss);
end.

(2.3k баллов)