Здравствуйте. Нужно написать программу ** Pascal ABC Net. Суть программы такова, что...

0 голосов
34 просмотров

Здравствуйте. Нужно написать программу на Pascal ABC Net. Суть программы такова, что нужно человеку сначала ввести n чисел, после чего программа должна сложить данные числа и эту сумму поделить на сумму чисел в числе,которое получилось в первой сумме, когда человек вводил числа.
Формула: \frac{ sum_{1} }{sum_{2}}
где sum1= сумму n чисел, которые ввёл человек
sum2=сумму чисел в числе, получившееся в результате сложения чисел, вводимых человеком.

ДАЮ 100 БАЛЛОВ ЗА НАПИСАНИЕ ТАКОЙ ПРОГРАММЫ!


Информатика (2.8k баллов) | 34 просмотров
Дано ответов: 2
0 голосов
Правильный ответ

// PascalABC.NET 3.3

begin
  var n:=ReadInteger('n =');
  var a:=ReadSeqInteger('Введите '+n+' чисел: ',n);
  var sum1:=a.Sum;
  var x:=sum1;
  var sum2:=0;
  while (x>0) do 
   begin
   sum2:=sum2+x mod 10;
   x:=x div 10;
   end;
  writeln('sum1 = ',sum1,' sum2 = ',sum2,' sum1/sum2 = ',sum1/sum2);
end.

Пример:
n = 5
Введите 5 чисел:  2 7 4 3 5
sum1 = 21 sum2 = 3 sum1/sum2 = 7

(194k баллов)
0 голосов

Ну должно быть как то так .


image
(154 баллов)
0

Program1.pas(8) : Встречено '+', а ожидалось ';'

0

Это где i:i+1