Написать программу, которая запрашивает строку и выводит ** экран 1-й, 2-й и 5-й...

0 голосов
96 просмотров

Написать программу, которая запрашивает строку и выводит на экран 1-й, 2-й и 5-й символы.

Паскаль abc.


Информатика (41 баллов) | 96 просмотров
Дано ответов: 2
0 голосов
Правильный ответ

Var s:string;
begin
writeln('Введите строку:');
readln(s);
writeln('s[1] = ',s[1],', s[2] = ',s[2],', s[5] = ',s[5]);
end.

Пример:
Введите строку:
Microsoft
s[1] = M, s[2] = i, s[5] = o

(194k баллов)
0 голосов

Переводим строку в массив символов.По красоте можно создать отдельно массив.

var s : String;
begin
Read(s);
Writeln(s.ToCharArray()[0]);//число -1 т.к. начинается все с нуля
Writeln(s.ToCharArray()[1]);
Writeln(s.ToCharArray()[4]);
end.

(614 баллов)