** С++ Напишите программу, которая вводит два целых числа и находит их произведение, не...

0 голосов
217 просмотров

На С++
Напишите программу, которая вводит два целых числа и находит их произведение, не используя операцию умножения. Учтите, что числа могут быть отрицательными.

Входные данные
Входная строка содержит два целых числа.

Выходные данные
Программа должна вывести произведение введённых чисел.

Примеры
входные данные
6 12
выходные данные
72
входные данные
-7 15
выходные данные
-105


Информатика (340 баллов) | 217 просмотров
Дан 1 ответ
0 голосов
Правильный ответ

#include #include using namespace std;
int main(){    int a, b, c = 0;    cin >> a >> b;    if (abs(a) > abs(b))        swap (a, b);    for (int i = 0; i < abs(a); i++)    {        if ((a >= 0 && b >= 0) || (a < 0 && b < 0))            c += abs(b);        else            c -= abs(b);    }    cout << c;    return 0;}

(570 баллов)
0

Блин, криво скопировалось

0

#include
#include
using namespace std;

int main()
{
int a, b, c = 0;
cin >> a >> b;
if (abs(a) > abs(b))
swap (a, b);
for (int i = 0; i < abs(a); i++)
{
if ((a >= 0 && b >= 0) || (a < 0 && b < 0))
c += abs(b);
else
c -= abs(b);
}
cout << c;<br> return 0;
}

0

Вот

0

#include
#include
using namespace std;

int main()
{
int a, b, c = 0;
cin >> a >> b;
if (abs(a) > abs(b))
swap (a, b);
for (int i = 0; i < abs(a); i++)
{
if ((a >= 0 && b >= 0) || (a < 0 && b < 0))
c += abs(b);
else
c -= abs(b);
}
cout << c;<br> return 0;
}

0

В первых двух include почему-то удаляются названия библиотек :/