Вывести квадраты чисел от 1 до N. В ПАСКАЛЕ написать программу (НЕ ИСПОЛЬЗУЯ for)

0 голосов
32 просмотров

Вывести квадраты чисел от 1 до N.
В ПАСКАЛЕ написать программу (НЕ ИСПОЛЬЗУЯ for)


Информатика (1.0k баллов) | 32 просмотров
Дан 1 ответ
0 голосов
Правильный ответ

1)
// PascalABC.NET 3.3

begin
  var n:=ReadInteger('n =');
  Range(1,n).Select(i->i*i).Println;
end.

Пример:
n = 5
1 4 9 16 25

2)
var n,i: integer;
begin
write('N = ');
readln(n);
i:=0;
while (i  begin
 i:=i+1;
 write(i*i,' ');
 end;
end.

3)
var n,i: integer;
begin 
write('N = ');
readln(n); 
i:=0; 
repeat
 i:=i+1;
 write(i*i,' '); 
until i=n;
end.

Пример:
N = 5
1 4 9 16 25

(194k баллов)
0

Можно ли написать данную программу с while, repeat?

0

Он получил баллы за свой ответ, никто его больше решать не заставляет, я просто поинтересовался у Вас, высококвалифицированных специалистов в области програмирования

0

Прошу прощения, школьную программу я не в силах изменить

0

Вы, наверное, рассуждаете о школах с уклоном на Айти и ИКТ, а вот в обычных школах основываются на обычную программу ФГОС