Помогите создать программу PythonНапишите программу, которая получает два целых числа и...

0 голосов
180 просмотров

Помогите создать программу Python
Напишите программу, которая получает два целых числа и находит их произведение, не используя операцию умножения. Учтите, что числа могут быть отрицательными.
Пример:
Введите два числа: 10 -15
10*(-15)=-150


Информатика (144 баллов) | 180 просмотров
Дан 1 ответ
0 голосов
Правильный ответ

A=int(input('a = '));
b=int(input('b = '));
if (((a<0) & (b>0)) | ((a>0) & (b<0))): sgn=1;<br>else: sgn=0;
if (a<0): a=-a;<br>if (b<0): b=-b;<br>c=0;
while (a>0):
    if ((a & 1)==1): c+=b;
    a>>=1;
    b<<=1;<br>if (sgn==1): print('результат: ',-c);
else: print('результат: ',c);

a = - 42153689754
b = 7892456310201
результат:  - 332696154697212539380554
    

(9.7k баллов)