напишите программу вычисляющую значение функции y=1 при x<0, y=0 при x=0, y=-1 при x<0

0 голосов
93 просмотров

напишите программу вычисляющую значение функции y=1 при x<0, y=0 при x=0, y=-1 при x<0</p>


Информатика (52 баллов) | 93 просмотров
Дан 1 ответ
0 голосов
Правильный ответ

В условии опечатка: два раза написано x < 0.
1) Если функция имеет вид y = 1 при x > 0, 0 при x = 0, -1 при x < 0:
var
  x: real;
  y: integer;
begin
  readln(x);
  if x > 0 then
    y := 1
  else if x = 0 then
    y := 0
  else
    y := -1;
  writeln(y)
end.
2) Если функция имеет вид y = 1 при x < 0, 0 при x = 0, -1 при x > 0, надо просто поменять местами 1 и -1 в решении выше.

(148k баллов)