Составить программу, считывает 2 числа, если сумма этих чисел кратно 3, то результат...

0 голосов
44 просмотров

Составить программу, считывает 2 числа, если сумма этих чисел кратно 3, то результат уменьшает в 3 раза, в противном случае оставляет без изменений.


Информатика (12 баллов) | 44 просмотров
Дано ответов: 2
0 голосов

На c++, если тебе надо считывание с файла, то ответь я переделаю.
----------------------------
#include using namespace std;int main(){int a,b;cin>>a>>b;if((a+b)%3==0) cout<<(a+b)/3<<endl;else cout<<a+b<<endl;return 0;}<br>

(799 баллов)
0

#include (\n)
using namespace std;(\n)
int main(){(\n)
int a,b;(\n)
cin>>a>>b;(\n)
if((a+b)%3==0) cout<<(a+b)/3<<endl;(\n)<br> else cout<<a+b<<endl;(\n)<br> return 0;(\n)
}

0

почему здесь оно построчно, а в ответе все в одну строку?

0

где (\n) это переход на новую строку, я просто разметил, просто уберешь (\n) с каждой строки

0 голосов
// PascalABC.NET 3.3, сборка 1625 от 17.01.2018
// Внимание! Если программа не работает, обновите версию!

begin
  var (a,b):=ReadInteger2('Введите через пробел два числа');
  var r:=a+b;
  if r mod 3=0 then Writeln(r/3)
  else Writeln(r)
end.
(142k баллов)