Помогите написать программу ** языке с. x+t при x^2+ sint> 0,1 y={ 2x+t^2 при x^2+ sint<...

0 голосов
41 просмотров

Помогите написать программу на языке с.
x+t при x^2+ sint> 0,1
y={ 2x+t^2 при x^2+ sint< 0,1
x-t при x^2+ sint= 0,1


Информатика (20 баллов) | 41 просмотров
Дан 1 ответ
0 голосов
#include
#include
using namespace std;
 
int main()
{
int x = 0;
int t = 0;
int y = 0;
cin >> x >> t;
if (pow(x, 2) + sin(t) > 0.1) {
y = x + t;
} else if (pow(x, 2) + sin(t) < 0.1) {
y = 2 * x + pow(t, 2);
} else if (pow(x, 2) + sin(t) == 0.1) {
y = x - t;
}
cout << y;<br>return 0;
}
(4.2k баллов)