Здравствуйте. Нужно написать программу ** Pascal ABC Net. Суть программы такова, чтобы...

0 голосов
39 просмотров

Здравствуйте. Нужно написать программу на Pascal ABC Net. Суть программы такова, чтобы она рандомно выбирала цвета (красный, чёрный или зелёный), но с определёнными шансами, то есть Красный=43,75%, Чёрный=50% и Зелёный=6,25%. В результате программа должна выдать человеку какой цвет выпадет.
В множество Красного цвета входят числа: 1,5,7,9,11,13,15
В множество чёрных: 2,4,6,8,10,12,14,16
В множество Зелёных: 3.


Информатика (2.8k баллов) | 39 просмотров
Дан 1 ответ
0 голосов
Правильный ответ

Считая, что функция random() возвращает случайные числа с равномерным законом распределения и что 7/16*100 = 43,75, 8/16*100 = 50, 1/16 = 6,25, задачу можно решить так:
begin
 var c:=random(1,16);
 case c of
  1,5,7,9,11,13,15: writeln(c,' - Красный');
  2,4,6,8,10,12,14,16: writeln(c,' - Чёрный');
  else writeln(c,' - Зелёный');
  end;
end.

Пример:
7 - Красный

(194k баллов)