Язык программирования - C++. Напишите программу, которая вводит натуральное число N и находит все совершенные чис- ла в диапазоне от 1 до N.
#include using namespace std; int main() { int n = 0; cin >> n; for (int i = 1; i <= n; ++i) { <br> int a = 0; for (int j = 1; j < i; ++j) { if (i % j == 0) { a += j; } } if (a == i) { cout << i << endl;<br> } } return 0; }