29баллов Написать программу в паскале Напишите функцию, дающую первое местоположение в...

0 голосов
37 просмотров

29баллов
Написать программу в паскале

Напишите функцию, дающую первое местоположение в строке s1 символа, встречающегося в строке s2


Информатика (12 баллов) | 37 просмотров
Дан 1 ответ
0 голосов

Uses crt;
var s1,s2: string;
    x,y:integer;
function pos(s1,s2:string):integer;
         begin
         for x:=length(s1) downto 1  do
             for y:=length(s2)downto 1 do
             if (s1[x]=s2[y])  then pos:=x;
         end;
begin
     write('s1: '); readln(s1);
     write('s2: '); readln(s2);
     writeln(pos(s1,s2));
end.

(7.2k баллов)