Написать программу удаляющую из записи все четные цифры. Например. из числа 12345 должно...

0 голосов
66 просмотров

Написать программу удаляющую из записи все четные цифры. Например. из числа 12345 должно получится 135


Информатика (513 баллов) | 66 просмотров
0

На каком языке?

0

На c++ желательно

0

поздновато опомнился, конечно, но алгоритм у тебя есть ниже

0

Ну помогите,плиз

Дан 1 ответ
0 голосов

Var
t,s:String;
i:integer;
Begin
Readln(s);
For i:= 1 to length(s) do
  if i mod 2 = 0 then continue
    else t:= t +s[i];
Writeln(t);
end.

(8.8k баллов)
0

Что такое length(s) и для чего тут continue

0

length(s)- длина строки, континью - продолжить, можно было заменить на if i mod 2 = 1 then t:= t + s[i]

0

на с++ s.length()